
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20191203003348
template: 
currentrequest: /apps/pbcs.dll/article?avis=OK&date=20191201&category=SPORTS&lopenr=312019962&Ref=AR
currentrequestunmodified: /sports/20191201/nfl-chiefs-rock-raiders-broncos-win-on-last-gasp-fg
@templatetype: /apps/pbcs.dll/article?avis=OK&date=20191201&category=SPORTS&lopenr=312019962&Ref=AR
@pagetype: article
app version: 2.0.397
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="The Miami News-Record" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> NFL: Chiefs rock Raiders; Broncos win on last-gasp FG - Sports - The Miami News-Record - Miami, OK</title>
<!-- Meta Tags - Global Article6 guid: 6501B818-F3F9-48EA-9CFF-3773929FED64-->
<meta name="description" content="By Sam MellingerThe Kansas City StarKANSAS CITY, Mo. (TNS) &#8212; It remains quite possible that Philip Rivers is done like dinner and the Raiders are merely finding their level, but there is another possibility here, too, one that may just change the trajectory of the Chiefs and thus the AFC.And, well, anyway, it&#8217;s at least worth considering:Are the Chiefs good at defense now?Like, not just not awful, or no longer a huge problem, or, even decent.But good.Like, good enough to help win a" />
<meta property="bt:pubDate" content="20191201T21:17:38Z">
<meta property="bt:modDate" content="20191202T04:51:00Z">
<meta property="bt:author" content="">
<meta name="twitter:title" content="NFL: Chiefs rock Raiders; Broncos win on last-gasp FG">
<meta name="twitter:description" content="By Sam MellingerThe Kansas City StarKANSAS CITY, Mo. (TNS) &#8212; It remains quite possible that Philip Rivers is done like dinner and the Raiders are merely finding their level, but there is another possibility here, too, one that may just change the trajectory of the Chiefs and thus the AFC.And, well, anyway, it&#8217;s at least worth considering:Are the Chiefs good at defense now?Like, not just not awful, or no longer a huge problem, or, even decent.But good.Like, good enough to help win a">
<meta property="og:title" content="NFL: Chiefs rock Raiders; Broncos win on last-gasp FG"/>
<meta property="og:description" content="By Sam MellingerThe Kansas City StarKANSAS CITY, Mo. (TNS) &#8212; It remains quite possible that Philip Rivers is done like dinner and the Raiders are" />
	<meta name="twitter:card" content="summary">
		<meta name="twitter:image" content="https://www.miamiok.com/Global/images/head/nameplate/fb/miamiok_logo.png">
		<meta property="og:image" content="https://www.miamiok.com/Global/images/head/nameplate/fb/miamiok_logo.png">
		<meta property="og:image:width" content="200">
		<meta property="og:image:height" content="200">
	<meta property="vf:unique_id" content="siteOK-pub3677-6501B818-F3F9-48EA-9CFF-3773929FED64">
	<link rel="canonical" href="https://www.miamiok.com/sports/20191201/nfl-chiefs-rock-raiders-broncos-win-on-last-gasp-fg"/>
<link rel="amphtml" href="https://www.miamiok.com/sports/20191201/nfl-chiefs-rock-raiders-broncos-win-on-last-gasp-fg?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.miamiok.com/sports/20191201/nfl-chiefs-rock-raiders-broncos-win-on-last-gasp-fg"
	},
    "headline": "NFL: Chiefs rock Raiders; Broncos win on last-gasp FG",
    "url": "https://www.miamiok.com/article/20191201/SPORTS/312019962",
    "thumbnailUrl": "https://www.miamiok.com/apps/pbcsi.dll/bilde?Site=OK&Date=20191201&Category=SPORTS&ArtNo=312019962&Ref=AR",
    "dateCreated": "20191202T03:17:38Z",
    "datePublished": "20191202T03:17:38Z",
    "dateModified": "20191202T10:51:00Z",
    "publisher": {
       "@type": "Organization",
       "name": "The Miami News-Record",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.miamiok.com/Global/images/head/nameplate/miamiok_logo.png"
       }
    },
    "articleSection": "Sports",
    "keywords": [""],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "The Miami News-Record",
    "productID": "miamiok.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="1683041798608259"/>
<meta name="twitter:site" content="@miaminewsrecord">
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>
<script>
window.ia = window.ia || function ()
{ (window.ia.q = window.ia.q || []).push(arguments); }
;
ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script>
docReady(function()
{ ims.startServices(); }
);
</script>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.397/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
    	@media only screen and (min-width: 768px) {
			#interstitial{display:none;}
		}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		          
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
				<script type="text/javascript">
  var TriggerPrompt = function(articleUrl, contentId) {
	if (!$(".p402_premium").length) {
		setTimeout(function(){ TriggerPrompt(articleUrl, contentId) }, 500);
		return;
	}
    var ARTICLE_URL = articleUrl ? articleUrl : window.location.href,
		CONTENT_ID 	= contentId ? contentId : 'everything',
		el 			= document.createElement('script'),
		url 		= '//survey.g.doubleclick.net/survey?site=_qtwhn5jyp5zu43bz3jjvmh7rgy' +
              '&url=' + encodeURIComponent(ARTICLE_URL) +
              (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
              '&random=' + (new Date).getTime() +
              '&after=1';
    el.setAttribute('src', url);
    var head = document.getElementsByTagName('head')[0] ||
        document.getElementsByTagName('body')[0];
    head.appendChild(el);
  };
  function pressplusAlternateAction() {
	__gh__webApp.paywall.showUserLoginForm();
  }
</script>

					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.miamiok.com/news" target="_top">News</a></li><li><a href="https://www.miamiok.com/sports" target="_top">Sports</a></li><li><a href="https://www.miamiok.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.miamiok.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.miamiok.com/obituaries" target="_top">Obituaries</a></li><li><a href="http://miaminewsrecord.ok.newsmemory.com/" target="_blank">E-Edition</a></li><li><a href="https://www.miamiok.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.miamiok.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/moneo/category/Jobs/Help%20Wanted" target="_blank">Jobs</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/moneo" target="_blank">Classifieds</a></li><li><a href="https://www.google.com/maps/d/u/0/edit?mid=1ivpDtGt_t_JH1exu3aEji34xde5EH2cn&ll=36.88310592675542%2C-94.76282445000004&z=10" target="_top">Map Directory</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.miamiok.com/subscribenow?g2i_source=miamiok.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-login">
					<a class="hide" data-gh-paywall-event="login" href="/login">
						<i class="fa fa-user"></i>
						<span class="hidden-sm hidden-xs">Log in</span>
					</a>
				</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.miamiok.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
			<style>@media screen and (max-width:479px){#header-main #toprail-nav-left{-webkit-box-flex:0;-moz-box-flex:0;box-flex:0;-webkit-flex:0;-moz-flex:0;-ms-flex:0;flex:0;}}</style>
		<div id="toprail-microbar">
			<div class="ad text-center">
				<div class="ad ad-topbanner text-center" data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Micro Bar","sov":"base ROS","allow_adx":"false"}' id="topBarSponsor" data-dimensions="[88,31]"></div>
			</div>
		</div>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.miamiok.com">
							<img class="mainheadnameplate" src="https://www.miamiok.com/Global/images/head/nameplate/miamiok_logo.png"  alt="The Miami News-Record" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.miamiok.com/subscribenow?g2i_source=miamiok.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.miamiok.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.miamiok.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>

				<div class="ad ad-billboard text-center" id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20191202045128">
	<div class="inner">
		<h1 class="headline">NFL: Chiefs rock Raiders; Broncos win on last-gasp FG</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			<div class="article-body">
				<span class="byline-item">
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Sunday</h3>
							<span class="article-meta-date">Dec&nbsp;1,&nbsp;2019&nbsp;at&nbsp;9:17&nbsp;PM</span>
							<span class="article-meta-updated">Dec&nbsp;2,&nbsp;2019&nbsp;at&nbsp;4:51&nbsp;AM</span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>By Sam Mellinger</p><br><p>The Kansas City Star</p><br><p>KANSAS CITY, Mo. (TNS) &#8212; It remains quite possible that Philip Rivers is done like dinner and the Raiders are merely finding their level, but there is another possibility here, too, one that may just change the trajectory of the Chiefs and thus the AFC.</p><br><p>And, well, anyway, it&#8217;s at least worth considering:</p><br><p>Are the Chiefs good at defense now?</p><br><p>Like, not just not awful, or no longer a huge problem, or, even decent.</p><br><p>But good.</p><br><p>Like, good enough to help win a playoff game?</p><br><p>This is two consecutive games the guys without Patrick Mahomes on their side of the ball have been somewhere between very good and dominant. Last week in Mexico City, they made the offense&#8217;s worst game of the season a footnote with four interceptions in a 24-17 win over the L.A. Chargers.</p><br><p>And, now, this group&#8217;s best defensive game since Denver with a blowout over the Raiders. And, obviously, its best defensive game against a representative NFL quarterback in much longer.</p><br><p>This reference may have a limited demographic, but I&#8217;m going to use it anyway:</p><br><p>Should we address the elephant in the room? This is two games in a row that Mahomes has been unproductive. His timing appears off, his footwork unhelpful and his accuracy unreliable. If he&#8217;s anything less than excellent, the Chiefs have little chance in January.</p><br><p>But, come on.</p><br><p>If it&#8217;s December and the Chiefs&#8217; biggest worry is the offense, then the Chiefs don&#8217;t have big worries.</p><br><p>The secondary, in particular, is playing exceptionally. The coverage has been superb, and here we should give special mention to Charvarius Ward. He has improved steadily over the last year, and for a month or two straight now has performed at the level of a No. 1 cornerback.</p><br><p>But this game belonged to the safeties, with Tyrann Mathieu and Juan Thornhill each intercepting Carr. Thornhill also made an aggressive and instinctual play near the line of scrimmage on a fourth-down run.</p><br><p>Disclaimers are in order here. Carr has always struggled against the Chiefs in general and at Arrowhead Stadium in particular. He is not the type of quarterback you have to beat in the postseason. The same could be said of Rivers, and the Chiefs are still soft against the run and vulnerable against running backs in the passing game.</p><br><p>Also, and most importantly, this is only two games.</p><br><p>But isn&#8217;t this how some of us thought it might go for their rebuilt defense? That they&#8217;d struggle early and find their strengths later?</p><br><p>However this goes in the coming month, the defense&#8217;s surge comes at an interesting moment. The Chiefs&#8217; next opponent, Tom Brady, is exactly the type of quarterback you have to beat in the postseason.</p><br><p>He has looked like an aging shell of his former self for much of the season, but he&#8217;s still Brady, and he has a long history of playing better as seasons progress, and especially in important games.</p><br><p>So let&#8217;s keep the optimism cautious, for now. But the Chiefs have a heck of an opportunity next week in New England.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>Broncos pull it out</p><br><p>DENVER (TNS) &#8212; The Los Angeles Chargers found a new way to lose during their rough season Sunday, falling 23-20 after a last-second pass interference penalty.</p><br><p>The infraction was called on cornerback Casey Hayward, a 37-yard mark-off that set up Brandon McManus&#8217; game-winning 53-yard field goal as time expired.</p><br><p>Denver took over for the final possession at its own 28-yard with only nine seconds remaining.</p><br><p>The Chargers appeared to send the game into overtime on a 46-yard field goal by Michael Badgley with 14 seconds remaining.</p><br><p>The kick came after they converted a fourth-and-11 following consecutive false start penalties on offensive linemen Dan Feeney and Russell Okung.</p><br><p>Mike Williams made a mostly one-handed catch over Denver cornerback Isaac Yiadom for a 38-yard gain and first down at the Denver 38-yard line with two minutes remaining.</p><br><p>Playing a Denver team missing pass rushers Von Miller and Bradley Chubb and starting a rookie quarterback, the Chargers instead looked like the undermanned team for most of Sunday.</p><br><p>Oddly, they were actually as healthy as they&#8217;ve been all year.</p><br><p>All-Pro safety Derwin James made his season debut after missing the first 11 games because of a stress fracture in his right foot.</p><br><p>Safety Adrian Phillips, a 2018 All-Pro on special teams, also played for the first time since Week 2 when he broke his arm during a loss in Detroit.</p><br><p>Starting offensive tackles Okung and Sam Tevi came back after being out with injuries.</p><br><p>Still, the Chargers were unable to overcome a sluggish start that saw them fall behind 14-0 early before rebounding to tie the score twice in the fourth quarter.</p><br><p>The Chargers fell to 4-8, the same record as Denver.</p><br><p>They pulled even 17-17 with a five-play, 62-yard touchdown drive in the fourth quarter. Keenan Allen reached the end zone to conclude a 36-yard reception by leaping over Denver safety Will Parks.</p><br><p>The Chargers had a chance to take the lead three minutes later, but Badgley&#8217;s 55-yard field goal attempt hit the left upright.</p><br><p>The kick came from five yards longer after Philip Rivers was sacked on third down. The miss also meant the Chargers couldn&#8217;t capitalize on linebacker Denzel Perryman&#8217;s diving interception that gave them the ball at the Denver 38-yard line.</p><br><p>Coming off back-to-back games in which he threw seven interceptions, Rivers was picked off to end the Chargers&#8217; second possession.</p><br><p>He was attempting to throw a screen to Austin Ekeler but instead the pass hit defensive end Dre&#8217;Mont Jones in the hands.</p><br><p>Six plays later, rookie quarterback Drew Lock connected with Courtland Sutton for a five-yard score to put the Broncos up 14-0 with 16 seconds left in the opening quarter.</p><br><p>Lock and Sutton had hooked up on a 26-yard touchdown on Denver&#8217;s second possession, with Sutton making a diving, one-handed grab to beat Chargers cornerback Hayward.</p><br><p>The early deficit was nothing new for the Chargers this season, especially against the Broncos. During a Week 5 loss to Denver at Dignity Health Sports Park, the Chargers also trailed 14-0 after one quarter and 17-0 at halftime.</p><br><p>On Sunday, though, they responded quicker. After both teams kicked field goals, the Chargers&#8217; offense showed its first life of the day when Rivers hit Williams for a 52-yard gain in the final minute of the second quarter.</p><br><p>Following a false start penalty, Rivers and Ekeler got together for a 30-yard touchdown pass to make it 17-10 at halftime.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>Rams bury Cardinals</p><br><p>GLENDALE, Ariz. (TNS) &#8212; The phrase developed into a familiar refrain from Los Angeles Rams quarterback Jared Goff.</p><br><p>Each week of the last month seemed to begin and end with Goff repeating what sounded like a mantra:</p><br><p>&#8220;I need to be better.&#8221;</p><br><p>On Sunday, Goff finally delivered.</p><br><p>He passed for 424 yards and two touchdowns as the Rams defeated the Arizona Cardinals 34-7 at State Farm Stadium.</p><br><p>The Rams improved to 7-5, keeping alive their playoff possibilities.</p><br><p>Six days after the Baltimore Ravens routed them 45-6, the Rams gave up only a fourth-quarter touchdown to fall shy of posting their first shutout since 2017, when they defeated the Cardinals 33-0 in London.</p><br><p>That also was the locale of Goff&#8217;s last touchdown pass.</p><br><p>He had not connected with a receiver in the end zone since an Oct. 27 victory over the Cincinnati Bengals at Wembley Stadium. The three-game drought was the longest of Goff&#8217;s NFL career.</p><br><p>But Goff found tight end Tyler Higbee for a touchdown in the second quarter and wide receiver Cooper Kupp in the third quarter for a 27-0 lead.</p><br><p>Goff completed 32 of 43 passes before he was replaced by Blake Bortles midway through the fourth quarter. Goff&#8217;s 424 yards passing were the third most in his career. He passed for 517 yards in a Sept. 29 loss to the Tampa Bay Buccaneers and 465 yards in a 2018 victory over the Minnesota Vikings.</p><br><p>Goff&#8217;s big performance came with a caveat: The Cardinals were ranked second to last in the NFL in total defense and dead last in pass defense.</p><br><p>But it was still a much-needed confidence boost for Goff, who has been under fire for performing well below the level that earned him consecutive Pro Bowl selections the last two seasons. In the days leading up to Sunday&#8217;s game, Goff said he did not feel extra pressure to live up to the $134 million extension he received before the season, but he stressed that he needed to be better.</p><br><p>Goff recaptured some of his previous form by relying heavily on Higbee and receiver Robert Woods. Higbee caught seven passes for 107 yards, both career bests. Woods had 13 receptions for 172 yards.</p><br><p>Goff extended a 20-0 halftime lead with his touchdown pass to Kupp midway through the third quarter.</p><br><p>On the ensuing possession, rookie safety Taylor Rapp returned an interception for a touchdown, providing a highlight-reel play for a defense that neutralized rookie quarterback Kyler Murray.</p><br><p>Murray, the No. 1 pick in the 2019 NFL draft, completed 19 of 34 passes for 163 yards. He rushed for 28 yards and a touchdown in four carries as the Cardinals fell to 3-8-1.</p><br><p>The Rams have four games remaining and probably need to win all of them to be in contention for a third consecutive playoff berth.</p><br><p>Next Sunday, they play the Seattle Seahawks at the Coliseum. Road games against the San Francisco 49ers and the Dallas Cowboys precede the finale at home against the Cardinals.</p><br><p>The NFC West-leading 49ers are 10-2 after losing to the Ravens on Sunday. The Seahawks (9-2) play the Minnesota Vikings (8-3) on Monday night &#8212; and the Rams could use some help from their division rival as they attempt to catch the Vikings in the race for an NFC wild-card spot.</p><br><p>Goff completed 24 of 31 passes for 323 yards and a touchdown in the first half as the Rams took a 20-0 lead. Higbee caught nine passes for 112 yards and the touchdown, and Woods had seven receptions for 107 yards.</p><br><p>The Rams&#8217; first drive stalled at the Cardinals&#8217; nine-yard line, forcing them to settle for a field goal. It appeared as if it might be another unproductive day for the offense when another drive stalled and Greg Zuerlein missed a 41-yard field-goal attempt.</p><br><p>Goff and Higbee connected for a 26-yard gain on the next drive and then capped it early in the second quarter with a two-yard touchdown for a 10-0 lead.</p><br><p>Gurley rushed for a touchdown with less than three minutes left, and Goff deftly executed a two-minute drive that ended with Zuerlein&#8217;s 33-yard field goal as time expired in the half.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>Ravens devour 49ers</p><br><p>BALTIMORE (TNS)&#8212; The offensive show wasn&#8217;t quite as dazzling for quarterback Lamar Jackson and the Baltimore Ravens on Sunday afternoon, when they squared off with the rugged defense of the San Francisco 49ers in driving rain at M&T Bank Stadium. But they continue to pile up victories.</p><br><p>Jackson threw for one touchdown and ran for another, Justin Tucker kicked a field goal as time expired, and the Ravens extended their winning streak to eight games by beating the 49ers, 20-17.</p><br><p>&#8220;It was a gritty game,&#8221; Ravens Coach John Harbaugh said. &#8220;I think it was a grit win for us.&#8221;</p><br><p>Tucker&#8217;s 49-yarder won it for the Ravens after they converted on fourth and one from their own 44-yard line on their winning drive. Harbaugh, once a coach about as buttoned-down as they come, has become an analytics-driven fourth-down gambler with Jackson orchestrating the league&#8217;s most dynamic offense.</p><br><p>&#8220;We knew we were going to go for fourth and one at that point, if we got in that situation,&#8221; Harbaugh said. &#8220;We probably weren&#8217;t going longer, maybe. Maybe I would have gone fourth and two. I don&#8217;t know. But that was already decided.&#8221;</p><br><p>That final gamble by Harbaugh came after the teams had traded failed fourth-down tries earlier in the fourth quarter. The Ravens upped their record to 10-2 and remained on the heels of the New England Patriots for the top seed in the AFC playoffs.</p><br><p>Jackson ran for 101 yards but had a modest 105 passing yards on 14-for-23 throwing accuracy. He called the conditions &#8220;horrible&#8221; for passing and acknowledged that he had gotten frustrated about that.</p><br><p>&#8220;It was ticking me off,&#8221; Jackson said. &#8220;A lot of passes were getting away from me.&#8221;</p><br><p>The Niners dropped to 10-2 as they try to stay ahead of the Seattle Seahawks in the NFC West and vie with the Seahawks and New Orleans Saints for the NFC&#8217;s No. 1 seed. Both of their losses this season - to the Seahawks in overtime and now to the Ravens - have come on final-play field goals. There is no time for the 49ers to lament this defeat, because they play at New Orleans next Sunday.</p><br><p>&#8220;We gave ourselves a chance,&#8221; cornerback Richard Sherman said. &#8220;That&#8217;s all you can do&#8230; . We just didn&#8217;t make enough plays there.&#8221;</p><br><p>If this was a Super Bowl preview, the rematch in Miami should be competitive and entertaining. These two teams played a tight and compelling game in difficult conditions Sunday.</p><br><p>&#8220;I don&#8217;t think about February while we&#8217;re in December,&#8221; Sherman said. &#8220;We&#8217;ve got a lot of time, a lot of things to happen, four games to go. We&#8217;re going to get ready for New Orleans, and we&#8217;ll let the chips fall where they may in February.&#8221;</p><br><p>The game&#8217;s early going saw the Ravens punt for the first time with Jackson still in a game since Week 9 and trail for the first time since Week 7. They managed to lead 17-14 at halftime after deflecting a missed 51-yard field goal try by Niners kicker Robbie Gould as time expired in the first half.</p><br><p>The Niners struck first on a 33-yard touchdown pass from quarterback Jimmy Garoppolo to wide receiver Deebo Samuel on a fourth-and-two play. Samuel outmaneuvered Ravens cornerback Marcus Peters on what amounted to a jump ball. The Ravens got even by converting a fumble lost by Garoppolo on a sack into a touchdown pass from Jackson to tight end Mark Andrews.</p><br><p>In the second quarter, the Ravens sandwiched a touchdown run by Jackson and a field goal by Tucker around a 49ers&#8217; touchdown on a 40-yard dash by running back Raheem Mostert. Sherman said the Baltimore offense was &#8220;about the same&#8221; as the 49ers expected. He praised the play of Jackson, a top league MVP contender.</p><br><p>&#8220;He&#8217;s a good decision-maker,&#8221; Sherman said. &#8220;He knows his angles. He knows his leverage. He knows when to get down. He knows when to stay up. He knows when to cut back, when to bounce outside. He knows when to keep it. He doesn&#8217;t take more than the defense will give him. He doesn&#8217;t waste time taking shots or looking downfield when it&#8217;s not there. He&#8217;ll check it down and take what the defense gives him. So it&#8217;s cool. He played a good game.&#8221;</p><br><p>The Niners tied the game at 17 on a third-quarter field goal by Gould. Earlier in the quarter, 49ers safety Marcell Harris made a spectacular defensive play by taking the football from Jackson&#8217;s hands at the end of a run. But it all came down to a kick by the ultra-reliable Tucker, something the Ravens will take every time.</p><br><p>&#8220;The conditions were not great,&#8221; Tucker said. &#8220;But being able to come through for this team in that moment is really special.&#8221;</p><br><p>Said Harbaugh: &#8220;You wouldn&#8217;t rather have anybody else in that situation. That field, that wind, that rain, all that stuff that was going on there - that&#8217;s the guy you want in that situation. I&#8217;m very grateful that we have him on Thanksgiving weekend.&#8221;</p><br><p>&#8212;&#8212;-</p><br><p>Bucs rip Jags</p><br><p>JACKSONVILLE, Fla. (TNS) &#8212; At times, the boos were loud and so were the chants for rookie quarterback Gardner Minshew to come off the bench and contribute Sunday afternoon at TIAA Bank Field.</p><br><p>Nick Foles, whom the Jaguars signed to a four-year, $88 million contract last March to deliver big plays as their franchise quarterback, could not avoid fumbling, stumbling or getting picked off against the Tampa Bay Buccaneers.</p><br><p>It was enough for Coach Doug Marrone to pull the plug on Foles and reinsert Minshew as his starting quarterback after halftime.</p><br><p>By then, the Buccaneers had already taken control of the game on their way to a 28-11 victory after spotting themselves a 25-0 halftime lead.</p><br><p>It was the Jaguars&#8217; (4-8) fourth straight loss with four games left in the regular season.</p><br><p>Minshew, however, still showcased his magic after Foles couldn&#8217;t do much of anything right.</p><br><p>Now, there&#8217;s a chance Minshew could start next week against the Los Angeles Clippers based on his performance Sunday.</p><br><p>Minshew led the Jaguars to two scoring drives, which included a 3-yard touchdown pass to Dede Westbrook that cut the Buccaneers&#8217; lead to 25-11 early in the fourth quarter.</p><br><p>Minshew almost led the Jaguars to their third scoring drive, but on a third-and-goal from 2 play the Buccaneers intercepted his pass intended for Westbrook with 6:06 left in the game,</p><br><p>Still, Minshew was back scrambling. He was back connecting to open receivers like he did when he filled in for then injured Foles and had a 4-4 record as a starter.</p><br><p>With Minshew giving a stagnant offense some life, the crowd was back engaged and cheering throughout the second half.</p><br><p>Minshew complted 15 of 26 for 141 yards and he was intercepted once and lost a fumble.</p><br><p>Before Minshew Mania returned, Foles was a big contributor to the Jaguars disastrous start.</p><br><p>On three consecutive drives in the first half, Foles turned the ball over three times, all leading to Tampa Bay touchdowns and a 22-0 point lead that they extended to 25-0 at halftime after a 25-yard field goal by Matt Gay.</p><br><p>Foles&#8217; disastrous day began on the Jaguars&#8217; opening drive after tossed an underneath pass attempt intended for Westbrook that was intercepted by Tampa Bay linebacker Devin White.</p><br><p>Five plays later Tampa Bay was in the end zone &#8212; Peyton Barber went untouched up the middle for a 15-yard touchdown run.</p><br><p>On the Jaguars&#8217; second drive, Foles was stripped-sacked by outside linebacker Shaquil Barrett and White scoped up the loose ball to score on a 14-yard fumble recovery.</p><br><p>Early in the second quarter, Foles was sacked again and fumbled that was recovered by Ndamukong Suh at the Tampa Bay 17. Just over three minutes later, Tampa Bay was back in the end zone on Barber&#8217;s second TD run, 1-yard up the middle.</p><br><p>Foles completed only 7 of 14 passes for 93 yards before he was benched.</p><br><p>In a season that&#8217;s essentially lost, the Jaguars were still unable to keep pace with the Buccaneers. Quarterback Jameis Winston completed 21 of 233 for 268 yards.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>&#8216;Skins rally to win</p><br><p>CHARLOTTE, N.C. (TNS) &#8212; The Carolina Panthers discovered yet another new way to lose Sunday.</p><br><p>Looking at first certain to win in the first quarter, then likely to have a chance to tie the game with a first-and-goal from the 1 in the last minute of the game, the Panthers ended up losing, 29-21, to Washington.</p><br><p>Washington entered the game with a 2-9 record, an interim head coach and a rookie quarterback. Washington exited Charlotte with a 29-21 win, coming back from an early 14-0 deficit by running the ball down Carolina&#8217;s throat and almost completely shutting down the Panthers&#8217; offense after the first quarter.</p><br><p>Desperately needing a win to keep its faint playoff hopes alive, Carolina dropped to 5-7 with its fifth loss in the last six games and its fourth in a row.</p><br><p>The Panthers mounted a ferocious late rally, scoring once in the final two minutes and then recovering an onside kick. But the final drive failed when Carolina&#8217;s four plays inside the 5 in the final minutes resulted in two Christian McCaffrey runs for lost yardage, a Kyle Allen incompletion and then a Washington sack.</p><br><p>The errors came from everywhere after the first quarter until the final two minutes. Panthers fans watched in disbelief while their defense got steamrolled against the run, allowing 248 rushing yards and dropping to 2-4 at Bank of America Stadium this season.</p><br><p>&#8212; The game was marred by the departure of tight end Greg Olsen, the 13-year veteran who entered the concussion protocol after sustaining a helmet-to-helmet hit in the third quarter from Washington linebacker Ryan Anderson. Olsen appeared to be knocked out immediately on the play, as he fumbled the ball and lay on his back after being concussed on the hit.</p><br><p>Anderson was called for a 15-yard penalty and disqualified from the game. Olsen got up and walked off the field under his own power before jogging to the locker room.</p><br><p>&#8212; The Panthers&#8217; offensive line had all sorts of problems, as Allen was sacked over and over. Allen also threw a bad interception at his own 10-yard line which led to a Washington touchdown. Allen completed his first eight passes of the day, throwing two touchdowns during that stretch, but then could barely get anything going the rest of the day. He did run for a 17-yard touchdown late in the fourth quarter for his third touchdown of the day.</p><br><p>&#8212; The loss broke an 11-game Carolina streak in which the halftime score had mimicked the final score. Carolina had been 5-0 when leading at halftime and 0-6 when trailing. However, Carolina led this game at halftime, 14-12.</p><br><p>&#8212; Before the Panthers were ever born, Charlotte was Washington territory. The Washington games were televised almost every Sunday afternoon, which meant a couple of generations of Carolinians grew up as Washington fans. So it wasn&#8217;t surprising that, even entering the game at 2-9, there was a lot of burgundy in the stands.</p><br><p>? Joe Gibbs, who won three Super Bowls as Washington&#8217;s coach and just won his fifth NASCAR championship at the sport&#8217;s highest Cup level, came to Sunday&#8217;s game. Gibbs was originally offered the Panthers&#8217; head-coaching job for the team&#8217;s inaugural season in 1995 but turned it down and Dom Capers eventually got the job.</p><br><p>? There were plenty of things you could complain about on the field Sunday, but the weather wasn&#8217;t one of them. While there were several snowy or rainy stadiums throughout the NFL Sunday, the sun came out for the game after a rainy morning and it stayed sunny and in the 60s all afternoon in the Queen City.</p><br><p>? After missing three times against New Orleans last week, Panthers placekicker Joey Slye had a much quieter day vs. Washington. Slye made his three extra points and didn&#8217;t get the opportunity to try any field goals.</p><br><p>? The wind was gusting at up to 20 mph on the field, which particularly affected the punting. Washington&#8217;s Tress Way boomed a 79-yarder in the third quarter.</p><br><p>? The prettiest play of the game from Carolina&#8217;s standpoint came on punter Michael Palardy&#8217;s onside kick, which completely fooled Washington and was recovered by linebacker Jermaine Carter.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>Bengals claw past Jets</p><br><p>CINCINNATI (TNS) &#8212; Just when you thought the Jets had distanced themselves from the NFL&#8217;s bottom feeders, Adam Gase made an emphatic case that his team deserves a spot on the Mount Rushmore of Dreck.</p><br><p>Gang Green&#8217;s Era of Good Feelings lasted a grand total of three weeks before they were embarrassed, 22-6, by the previously winless Bengals on Sunday.</p><br><p>It was the second time in five weeks that Gase handed an opponent their first win of the season. Rock bottom might have been falling to the 0-7 Dolphins, but this was equally painful.</p><br><p>The harsh truth: Cincinnati out-played and out-coached the Jets (4-8) in every imaginable way, a bitter pill to swallow given its season-long ineptitude. The Bengals had been an unmitigated disaster for three months, a punching bag for the rest of the league, before controlling this game.</p><br><p>The football gods handed the Jets a de facto second bye against these tomato cans, but the tryptophan evidently was still in Gang Green&#8217;s system. Gase&#8217;s club looked nothing like the improving group after a nightmarish first half of the season.</p><br><p>How could a team that scored 34 points for three consecutive games lay an egg to arguably the worst team in the sport? Maybe the answer isn&#8217;t that difficult to uncover. Maybe the past few weeks were a mirage against cream puffs. Maybe their success was destined to be fleeting.</p><br><p>Maybe the Jets just stink too.</p><br><p>Gase&#8217;s team was an undisciplined, disjointed mess. Poor execution coupled with poor coaching leads to a predictable result. The Jets were plagued by penalties and weird play-calling to officially bury any pie-in-the-sky thought that they could rally to sneak into the playoffs. Gang Green will miss the postseason for a ninth consecutive year.</p><br><p>The Jets offensive line (seven penalties) and secondary weren&#8217;t nearly good enough to stop the Bengals from snapping their season-long 11-game losing streak. Gase&#8217;s decision to air it out in the first half rather than feast on the league&#8217;s worst run defense was a head scratcher.</p><br><p>Gase&#8217;s offense never got on track against a team that had lost its first five home games by an average of 16 points and had been giving up 26.5 point a week. It was equal parts strange and laughable. The Jets have hardly been world beaters, but they weren&#8217;t exactly facing the Steel Curtain.</p><br><p>The Jets dug a 17-6 halftime hole thanks to ill-timed penalties, drops and curious play-calling. Gase curiously dialed up 26 passes and only nine runs before the break against the NFL&#8217;s worst run defense. The Bengals had allowed a league-high 166 yards on the ground this season, but Gase opted not to lean on Le&#8217;Veon Bell, who had just five carries in the first half.</p><br><p>Meanwhile, Andy Dalton, rejuvenated after a three-game benching, leaned on tight end C.J. Uzomah and wideout Tyler Boyd, who combined for nine catches, 101 yards and a touchdown to help build the double-digit halftime lead.</p><br><p>Sam Darnold threw 25 passes in a one-possession game for much of the first half. It was a mind-boggling approach by Gase, whose offense had been on fire (against bad defenses) in recent weeks. To make matters worse, Gang Green shot themselves in the foot with offensive and defensive penalties to fall behind the most inept team in the league.</p><br><p>Believe it or not, it got worse in the second half.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>Steelers nip Browns</p><br><p>PITTSBURGH (TNS) &#8212; The Browns watched their playoff hopes dwindle to virtually nothing Sunday with a 20-13 loss to the Pittsburgh Steelers at Heinz Field.</p><br><p>Two days after Browns coach Freddie Kitchens wore a &#8220;Pittsburgh started it&#8221; T-shirt to a movie theater in reference to the Nov. 14 brawl between the AFC North foes, the Steelers finished Cleveland&#8217;s three-game winning streak.</p><br><p>Kitchens posed for a photograph with a fan while donning the shirt, and the picture surfaced on social media and went viral. Now the gaffe could haunt Kitchens with questions about his job security surrounding the organization.</p><br><p>Instead of earning a season sweep of the Steelers for the first time since 1988, the Browns (5-7) suffered their 16th consecutive loss in Pittsburgh and haven&#8217;t prevailed there since Oct. 5, 2003.</p><br><p>During the second showdown between the two teams in 18 days, the Steelers (7-5) bounced back from a 10-0 deficit by going on a 20-0 run.</p><br><p>The Browns squandered an opportunity to bury the playoff chances of the Steelers, whose franchise quarterback Ben Roethlisberger suffered a season-ending elbow injury in Week 2. Roethlisberger owns a starting record of 22-2-1 against Cleveland.</p><br><p>With Roethlisberger out and backup Mason Rudolph benched, undrafted rookie Devlin Hodges prevailed over the Browns in just his second regular-season start in the NFL. Hodges went 14-of-21 passing for 212 yards and one touchdown with an interception and a rating of 95.7.</p><br><p>Browns quarterback Baker Mayfield didn&#8217;t fare as well. He hurt his right hand just before halftime but came back in the third quarter and finished the game. He went 18-of-32 passing for 196 yards with one touchdown and an interception for a rating of 71.9. He lost a fumble in the third quarter and took five sacks.</p><br><p>The Steelers punched the Browns in the mouth with a seven-play, 69-yard scoring drive to begin the second half. Running back Benny Snell rushed for a 1-yard touchdown with 10:36 left in the third quarter, allowing the Steelers to capture a 17-10 lead. During the previous play, Browns cornerback Denzel Ward was flagged for pass interference in the end zone against receiver Deon Cain on third-and-7 from the Cleveland 12.</p><br><p>Rather than countering, the Browns gave the ball back to the Steelers. On second-and-20 from the Pittsburgh 48, Steelers outside linebacker Bud Dupree strip-sacked Mayfield, and defensive tackle Cameron Heyward recovered the fumble at the Cleveland 46 with 4:49 left in the third quarter.</p><br><p>The Steelers turned the takeaway into three points and a 20-10 advantage when Chris Boswell made a 29-yard field goal with 13:48 left in the fourth quarter. The 10-play, 35-yard drive stalled at the Cleveland 3 with Browns rookie linebacker Mack Wilson forcing Hodges to fumble out of bounds.</p><br><p>The teams traded possessions before Browns ended the Steelers&#8217; 20-run when Austin Seibert made a 34-yard field goal, trimming Cleveland&#8217;s deficit to 20-13 with 7:30 left in the fourth quarter. The seven-play, 61-yard drive stalled at the 14, where Mayfield was sacked by Dupree and Heyward for a 2-yard loss on third down.</p><br><p>On the next play from scrimmage, cornerback Terrance Mitchell intercepted a pass from Hodges and returned it 28 yards to the Pittsburgh 30 with 7:18 remaining in the fourth quarter.</p><br><p>But the Browns went backward from there. On third-and-10 from the 30, Mayfield was sacked for an 8-yard loss by nose tackle Javon Hargrave. Seibert successfully pooch punted to the 1 with 5:35 left, though the Browns&#8217; defense failed to record a quick stop against Hodges and Co.</p><br><p>The Browns got the ball back at their 20 with 1:45 left, but on second-and-5 from the Pittsburgh 40, Steelers cornerback Joe Haden, who played for the Browns from 2010-16, intercepted a pass from Mayfield to seal the home team&#8217;s victory with 1:06 remaining.</p><br><p>Mayfield hurt his right hand late in the second quarter after his team blew a 10-point lead.</p><br><p>On second-and-10 at the Cleveland 36 line, Mayfield&#8217;s right hand hit the face mask of Dupree after he released the ball on a deep incomplete pass intended for Odell Beckham Jr. Mayfield immediately held the top of his thumb and left the game with seven seconds left in the second quarter.</p><br><p>Backup quarterback Garrett Gilbert entered the game and threw two incomplete passes before the Browns and Steelers entered halftime tied 10-10. Mayfield went 10-of-17 passing for 98 yards and a touchdown for a rating of 94.7 in the first half.</p><br><p>With a white glove on his throwing hand, Mayfield returned to the action when the Browns&#8217; first possession of the second half began. The series ended on its 10th play when Mayfield lost a fumble.</p><br><p>The way the game began, the Browns appeared to be capable of rolling to a big win.</p><br><p>They drew first blood with Seibert&#8217;s 31-yard field goal, which gave them a 3-0 lead with 9:38 left in the first quarter. More damage could have been done on the game&#8217;s opening possession, but the Browns stalled during the 13-play, 62-yard drive after facing first-and-6 at the Pittsburgh 6.</p><br><p>Earlier during the series, receiver Jarvis Landry made an incredible 15-yard catch along the Steelers&#8217; sideline to give the Browns a first down at the 11 on third-and-14 from the Pittsburgh 26. The officials initially ruled it was an incomplete pass but reversed the call after Browns coach Freddie Kitchens challenged it.</p><br><p>The Browns registered a three-and-out on their first defensive series. Defensive end Chad Thomas rushed past right tackle Matt Feiler and sacked Hodges for a 13-yard loss on third-and-6 from the Pittsburgh 45. It was the fourth sack of the season for Thomas, who started in place of the suspended Myles Garrett.</p><br><p>After the teams traded possessions, the Browns took control with a 10-play, 70-yard scoring drive.</p><br><p>On second-and-13 at the Steelers 23, outside linebacker T.J. Watt rushed unblocked and crushed Mayfield as the completed an 8-yard pass to Landry. Mayfield was shaken up, but he stayed in the game after the Browns used a timeout with 7:43 left in the second quarter.</p><br><p>Then on third-and-5, running back Kareem Hunt caught a short pass from Mayfield at the 13, made two defenders miss and reached the end zone for a 15-yard touchdown. Hunt&#8217;s catch and run allowed the Browns to go ahead 10-0 with 7:40 remaining in the second quarter.</p><br><p>But the Steelers countered by scoring on their next two possessions.</p><br><p>They capped a 10-play, 62-yard drive with Boswell&#8217;s 39-yard field goal to cut the Browns&#8217; lead to 10-3 with 2:56 left in the second quarter.</p><br><p>Then the Steelers finished a five-play, 69-yard march when Hodges and wide receiver James Washington connected in the front of the end zone for a 30-yard touchdown pass. Boswell&#8217;s successful extra point tied the score with one minute left before halftime.</p><br><p>Defensive tackle Larry Ogunjobi returned from his one-game suspension stemming from the Browns-Steelers melee two weeks ago, and defensive end Olivier Vernon came back from an injured right knee to play for the first time since Nov. 3. They combined with tackle Sheldon Richardson to give the Browns three-fourths of their starting defensive line back after it had been reduced to Richardson last week in a 41-24 win over the Miami Dolphins.</p><br><p>Garrett continued be the missing piece on the D-line due to the NFL suspending him indefinitely for ripping off the helmet of Rudolph and hitting the Steelers quarterback over the head with it two weeks ago. Garrett, in an appeal hearing, accused Rudolph of calling him a racial slur before the fight broke out.</p><br><p>Steelers seven-time Pro Bowl center Maurkice Pouncey didn&#8217;t appear in the rematch, either, because of his two-game ban for punching and kicking Garrett.</p><br><p>Meanwhile, Rudolph spent the Browns-Steelers sequel on the sideline because he was benched last week in favor of Hodges.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>Dolphins clip Eagles&#8217; wings</p><br><p>MIAMI (TNS) &#8212; This was the Dolphins best game of the season. Period.</p><br><p>They started terribly, with an interception on the first play of the game. They trailed by two touchdowns with 11:50 to play in the third quarter.</p><br><p>And then things got bonkers!</p><br><p>Ryan Fitzpatrick went crazy, throwing for 365 yards. The defense withstood Eagles rallies time and again. And coach Brian Flores tempted fate with an onside kick, multiple fourth-down attempts and the craziest touchdown of the season &#8212; a scoring pass from punter Matt Haack to kicker Jason Sanders off an unorthodox field goal formation.</p><br><p>Dolphins 37.</p><br><p>Eagles 31.</p><br><p>It was a great game, and I would encourage you to come back to this space in a couple of hours after I go to the locker room for Flores and player reaction. Meanwhile some quickie analysis:</p><br><p>&#8212; The Dolphins biggest star of the game was receiver DeVante Parker, who continues his most productive season since he was drafted in 2015.</p><br><p>Parker caught two touchdown passes among his seven receptions for 159 yards. He clearly overmatched Eagles cornerbacks in that he was not faster but simply bigger. And so he turned two 50-50 balls into catches and touchdowns.</p><br><p>It really was impressive in that this game sealed the fact Parker is better than he&#8217;s ever been for the Dolphins. He now has 62 catches for 853 yards. So Parker has a legitimate chance at his first career 1,000-yard season if he continues to play at this level the final four games of the season.</p><br><p>The beauty of this is that Parker is showing an aggressiveness we&#8217;ve not been used to previously. The light bulb is definitely on for him. And so is the confidence.</p><br><p>&#8212; Another recent Dolphins draft pick that is rising from possible bust status is tight end Mike Gesicki.</p><br><p>You have to understand he was never expected to be a physical presence in that he has never been a good blocker. And that&#8217;s fine if he wins in the secondary either against smaller corners and safeties or slower linebackers.</p><br><p>Well, Gesicki wasn&#8217;t winning those matchups until the past month or so. And now he&#8217;s on fire.</p><br><p>He scored a touchdown on Sunday, marking the second consecutive game he accomplishes that feat. Gesicki&#8217;s 14-yard score in the third quarter brought the Dolphins withing 28-26.</p><br><p>Gesicki finished with five catches for 79 yards and the score.</p><br><p>&#8212; All this was a result of excellent quarterback play by Ryan Fitzpatrick.</p><br><p>He threw an interception on his first pass, the first play of the game.</p><br><p>And then he simply went off &#8230;</p><br><p>Fitzpatrick completed 27 of his next 38 passes for 365 yards and three touchdown passes. He finished the day with a 113.7 quarterback rating.</p><br><p>With Fitzpatrick avoiding the rush and finding open receivers, the Dolphins scored on six consecutive possessions starting in the second quarter and into the fourth quarter, not counting a kneel down at before halftime.</p><br><p>The Dolphins trailed 28-14 and scored 23 consecutive points to take a 37-28 lead.</p><br><p>&#8212;&#8212;&#8212;</p><br><p>Pack drop Giants</p><br><p>NEW YORK (TNS) &#8212; Sunday&#8217;s 31-13 blowout Giants loss to the Green Bay Packers has Big Blue on the cusp of history.</p><br><p>And not the good kind.</p><br><p>The Giants (2-10) have lost eight straight games following Daniel Jones&#8217; three interceptions and Aaron Rodgers&#8217; easy, four-touchdown day on a snowy MetLife Stadium track.</p><br><p>That puts them one defeat shy of tying the franchise&#8217;s longest single-season losing streak ever, nine in a row in 1976, in the inaugural season at Giants Stadium.</p><br><p>The Giants visit the Philadelphia Eagles on Monday Night Football next weekend. The Eagles have won five straight in the head-to-head division rivalry.</p><br><p>Sunday&#8217;s loss also officially eliminated the Giants from the playoffs, but of course that was only a formality at this point. Tons of Packers fans chanted &#8220;Go Pack Go!&#8221; There were plenty of empty seats. And the Giants fans who were there streamed for the exits with seven minutes to play.</p><br><p>The Giants have the most losses in the NFL since the start of the 2017 NFL season (10-34).</p><br><p>Pat Shurmur has a 7-21 record (.250) as their head coach and a 17-44 (.278) career head coaching mark.</p><br><p>On Sunday, the Giants trailed 17-13 after a 45-yard Aldrick Rosas field goal with 6:37 remaining in the third quarter.</p><br><p>But Rodgers, who picked on slot corner Grant Haley often after Corey Ballentine (concussion) left midgame, drove the Packers 75 yards an early fourth quarter touchdown and a 24-13 lead. He hit Davante Adams, who&#8217;d beaten corner Sam Beal, for a 17-yard TD.</p><br><p>Then receiver Da&#8217;Mari Scott, whom the Giants cut wideout Bennie Fowler to sign off the practice squad, fumbled an exchange with Jones for an eight-yard loss. And Jones overthrew Sterling Shepard into the arms of the Packers&#8217; Darnell Savage.</p><br><p>The Packers drove and converted that into a Marcedes Lewis TD 1-yard TD catch and the final score. And Jones then threw a third pick that Tramon Williams snagged out of the air against Darius Slayton.</p><br><p>The Giants conceivably could own the No. 1 pick in April&#8217;s draft when all is said and done considering Washington, Miami and Cincinnati were all challenging for wins on Sunday.</p><br><p>And they could enter their Week 15 home game against the Dolphins with a chance to set the record for consecutive losses in one season by a Giants team. Ever.</p><br><p>A dubious distinction doesn&#8217;t even begin to describe what that would mean.</p><br><p>&#8212;&#8212;&#8212;&#8212;</p><br><p>Texans topple Pats</p><br><p>HOUSTON (TNS) &#8212; Tom Brady was frustrated.</p><br><p>Following a third-down incompletion in which Brady wanted rookie Jakobi Meyers to run upfield when the play broke down, the quarterback returned to the sideline hoping to fire up his receivers. The prior series had ended with an interception.</p><br><p>&#8220;We&#8217;ve got to be faster, quicker, more explosive, everything,&#8221; Brady could be seen saying on the Patriots bench. The quarterback finished the passionate speech with a few expletives before turning his attention to offensive coordinator Josh McDaniels.</p><br><p>There&#8217;s going to be a time where the Patriots offense has to pick up the slack and help the defense, which has carried the load for most of the 2019 season.</p><br><p>Sunday was not that time.</p><br><p>After winning two low scoring affairs in a row &#8212; 13-9 over Dallas and 17-10 over Philadelphia &#8212; the Patriots defense couldn&#8217;t hold the Texans under 20 points. Problems on both sides of the ball contributed to a 28-22 loss to Houston Sunday night.</p><br><p>The Pats drop to 10-2 and the Baltimore Ravens (10-2) move up to the AFC&#8217;s No. 1 seed with four games left this season.</p><br><p>Brady finished 24 of 47 for 326 yards with three touchdowns and one interception. James White (79 rushing yards, 98 receiving yards and two touchdowns) and Julian Edelman (six catches for 106 yards and a touchdown) led the way on offense. In the end, the Patriots couldn&#8217;t recover from their slow start.</p><br><p>New England started with a 23-yard field goal from Kai Forbath at 7:04 of the first quarter. The Texans defense stepped up the next time Brady stepped on the field as Bradley Roby intercepted the Patriots quarterback as Brady was trying to hit N&#8217;Keal Harry on a slant.</p><br><p>Three plays later, Deshaun Watson hit Duke Johnson for a 14-yard touchdown and Houston was in front, 7-3.</p><br><p>It didn&#8217;t get much better for the Patriots. The next offensive drive resulted in an incomplete pass on third down that had Brady so angry, he could be seen having an animated discussion with his receivers on the sideline.</p><br><p>On the next drive, the Texans took a 14-3 lead. Watson made multiple first-down throws before hitting tight end Darren Fells for a 13-yard touchdown at 6:21 of the second quarter.</p><br><p>Brady&#8217;s frustrations continued. The next drive ended with a sack on third down. The final Patriots drive before the half ended with three incomplete passes. Brady went into the half completing just 7-of-19 passes for 82 yards with a 28.8 quarterback rating.</p><br><p>His first pass of the third quarter was intercepted by Roby, but a defensive holding call wiped out the turnover. Houston got to Brady for a third-down sack to end the Patriots&#8217; first drive of the second half. The next series looked promising with a White 32-yard run, but it stalled at midfield as Brady&#8217;s pass on fourth-and-1 was dropped by Mohamed Sanu.</p><br><p>The decision to go for it on fourth down backfired as the Texans started their next drive near midfield. It didn&#8217;t take Watson long to extend Houston&#8217;s lead to 21-3. The quarterback initially hit Will Fuller for a 35-yard touchdown, but the officials ruled the play an incomplete pass. On the next play, on third down, Watson hit Kenny Stills for a 35-yard touchdown at 5:41 of the third quarter.</p><br><p>The Patriots found some life in their offense in the ensuing series to close the gap 21-9. Despite multiple penalties, the Patriots saw big catches from Ben Watson (23 yards on third-and-17) and Edelman (44 yards on first-and-30) to move downfield. With 11 seconds left in the third quarter, Brady hit White for a 12-yard touchdown. Forbath missed the extra point.</p><br><p>The defense, however, still couldn&#8217;t contain Watson. On the next series, Houston extended its lead to 28-9 when Watson scored on a 6-yard touchdown reception. It was a trick play that the Patriots fell for as the ball was snapped to running back Duke Johnson, handed to receiver DeAndre Hopkins, who threw the ball to Watson, who scored with 9:53 remaining.</p><br><p>The Patriots offense put together another nice drive following Watson&#8217;s score. A fourth-down conversion to Phillip Dorsett put the Pats at the 11-yard line. Two plays later, Brady hit White for an 11-yard touchdown with 3:42 left. The 2-point conversion failed when Brady&#8217;s pass to Dorsett fell incomplete and Houston led, 28-15.</p><br><p>The Texans then recovered Jake Bailey&#8217;s onside kick attempt. The Pats got the ball back with 2:36 left on the clock. Brady orchestrated another scoring drive &#8212; this time hitting Edelman for a 20-yard touchdown with 50 seconds left.</p><br><p>Bailey&#8217;s onside attempt was close as Bolden got a hand on the football, but the ball rolled out of bounds, securing Houston&#8217;s victory.</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.miamiok.com/subscribenow?g2i_source=miamiok.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
								<h2>Sign up for daily e-mails</h2>
										<form id="sfNewsletterForm_footer" class="sfNewsletterForm form-inline">
			<input type="email" name="sfUserEmail" class="sfUserEmail" placeholder="Enter Email Address">
			<input type="hidden" name="sfSource" class="sfSource" value="footer">
			<input type="submit" name="sfSignup" class="sfSignup btn btn-newsletter" value="Sign Up Now">
			<div class="sfResults">
			</div>
		</form>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://myprofile.miamiok.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTCP_MNR" target="_top">My Profile</a></li><li><a href="https://www.miamiok.com/contact" target="_blank">Contact Us</a></li><li><a href="https://www.miamiok.com/submit" target="_blank">Online Forms</a></li><li><a href="http://mediakit.gatehousemedia.com/Miami_OK" target="_blank">Advertise With Us</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.marketplaceadsonline.com/marketplace/moneo" target="_blank">Classifieds</a></li><li><a href="https://www.miamiok.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.miamiok.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/moneo/category/Jobs/Help%20Wanted" target="_blank">Jobs</a></li><li><a href="https://www.miamiok.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Community<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.miamiokla.net" target="_blank">City of Miami</a></li><li><a href="http://www.miamiokchamber.com" target="_blank">Chamber of Commerce</a></li><li><a href="http://www.miami.k12.ok.us" target="_blank">Miami Public Schools</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=OK&date=20191201&category=SPORTS&lopenr=312019962&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2019. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />The Miami News-Record  ~ 14 1st Ave. NW, 918-542-5533, Miami, OK 74354<span class="gdpr hide"> ~ <a href="javascript:void(0);" class="optanon-toggle-display" data-ignore-geolocation="true">Privacy Settings</a>  ~ <a href="https://www.miamiok.com/section/cookie-policy" target="_blank">Cookie Policy</a></span> ~ <a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.miamiok.com/subscribenow?g2i_source=miamiok.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.miamiok.com" target="_top">Home</a></li><li><a href="https://www.miamiok.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"11317"><a href="https://www.miamiok.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"11318"><a href="https://www.miamiok.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"11319"><a href="https://www.miamiok.com/news/state" target="_top">State</a></li><li id="navLink-TEST-"11320"><a href="https://www.miamiok.com/news/nation-world" target="_top">Nation/World</a></li><li id="navLink-TEST-"11321"><a href="https://www.miamiok.com/news/weather" target="_top">Weather</a></li><li id="navLink-TEST-"39498"><a href="https://www.miamiok.com/news/shareable" target="_top">Shareable</a></li></ul></li><li><a href="https://www.miamiok.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"11323"><a href="https://www.miamiok.com/sports/high-school" target="_top">High School</a></li><li id="navLink-TEST-"11324"><a href="https://www.miamiok.com/sports/college" target="_top">College</a></li></ul></li><li><a href="https://www.miamiok.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52400"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"11326"><a href="https://www.miamiok.com/lifestyle/celebrations" target="_top">Celebrations</a></li><li id="navLink-TEST-"11327"><a href="https://www.miamiok.com/lifestyle/faith" target="_top">Faith</a></li></ul></li><li><a href="https://www.miamiok.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"11329"><a href="https://www.miamiok.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"11330"><a href="https://www.miamiok.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.miamiok.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"39497"><a href="https://www.miamiok.com/entertainment/tv-guide" target="_top">TV Guide</a></li><li id="navLink-TEST-"38468"><a href="https://www.miamiok.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.miamiok.com/business-news" target="_top">Business</a></li><li><a href="https://www.miamiok.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.miamiok.com/photos" target="_top">Photos</a></li><li><a href="https://www.miamiok.com/submit" target="_top">Submit Your News</a></li><li><a href="https://www.miamiok.com/weather" target="_top">Weather</a></li><li><a href="https://www.miamiok.com/contests" target="_top">Contests</a></li><li><a href="https://www.miamiok.com/ara" target="_top">Branded Content</a></li><li><a href="http://local.miamiok.com/" target="_blank">Enhanced Business Listings</a></li><li><a href="https://www.miamiok.com/section/promoted//?prx_adpz=2233" target="_top">From Our Advertisers</a></li><li><a href="https://www.miamiok.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.miamiok.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTCP_MNR" target="_top">My Profile</a></li><li><a href="http://miaminewsrecord.ok.newsmemory.com/" target="_blank">E-Edition</a></li><li><a href="https://www.miamiok.com/subscribenow" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://www.marketplaceadsonline.com/marketplace/moneo" target="_blank">Classifieds</a></li><li><a href="http://findnsave.miamiok.com" target="_top">Find & Save</a></li><li><a href="https://www.miamiok.com/section/cars" target="_blank">Cars</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/moneo/category/Jobs/Help%20Wanted" target="_blank">Jobs</a></li><li><a href="https://www.miamiok.com/homes" target="_top">Homes</a></li><li><a href="http://mediakit.gatehousemedia.com/Miami_OK" target="_blank">Advertise With Us</a></li><li><a href="https://www.miamiok.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://miamiok.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:news@miaminewsrecord.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/terms_of_use/">Terms of Use</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/privacy-policy/">Privacy Policy</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/our-markets/">GateHouse Media Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.miamiok.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/miamioknews""
								target="_blank"
								title="The Miami News-Record Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="http://www.twitter.com/miaminewsrecord""
								target="_blank"
								title="The Miami News-Record Twitter">
								<i class="fa fa-fw fa-twitter"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="The Miami News-Record RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.miamiok.com/contact"
								title="Contact The Miami News-Record">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
        <a href="http://miamiok.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.miamiok.com/apps/pbcs.dll/article?avis=OK&date=20191201&category=SPORTS&lopenr=312019962&Ref=AR"}'>
            Learn More
        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.397/app.min.js" crossorigin="anonymous"></script>
		<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2019-12-03&nbsp;00:33:48-->
	<script async type="text/javascript" src="/_Incapsula_Resource?SWJIYLWA=719d34d31c8e3a6e6fffd425f7e032f3&ns=2&cb=613294444"></script>
</body>
</html>
